KeyFlow Pro

  • Q

    What are the minimum system requirements?

    A
    KeyFlow Pro requires Mac OS X 10.9.4 or later, 64-bit processor and 4GB of RAM (8GB or more recommended).
  • Q

    Which file formats are supported?

    A
    KeyFlow Pro supports almost all types(video, audio, image, document and extra) of file. Especially in the case of video, KeyFlow Pro embedded H.264 transcoder for preview based on AVFoundation by default. If you want to use the formats not supported by AVFoundation encoder (such as MXF, AVCHD, and XAVC formats), you should additionally install FFmpeg, then add to Encoder setting. In KeyFlow Pro 1.6 or later, you can import the RED formats (R3D and RMD files) by installing REDCINE-X PRO, then adding to Encoder setting in Preferences.
  • Q

    Which camera devices are supported?

    A
    KeyFlow Pro supports all kinds of digital camera devices supported by OS X.
  • Q

    If we were to purchase KeyFlow Pro once, we are able to install on 10 user’s machines? How does that work?

    A
    After creating an Apple ID of company, you can share it to other users and install it to other machines. How to install the app depends on the App Store policy. You can install any number of KeyFlow Pro licenses according to that policy, but the number of concurrent users is limited up to 12 per server. By default, KeyFlow Pro provides a 5-User Client Pack. More concurrent user licenses can be added through In-App Purchase. In the next version, a 10-User Client Pack will be added to In-App Purchase. Then, the number of concurrent users will be limited up to 22 per server.
  • Q

    Where can I store libraries?

    A
    KeyFlow Pro supports all kinds of volumes. So you can store libraries on local disks, DAS, NAS and SAN volumes.
  • Q

    What's the difference between "Copy to library" and "Leave files in place"?

    A
    Before you import media files into KeyFlow Pro, you can select the default option between ‘Copy to library’ or ‘Leave files in place’ in the General tab of Preferences.
    - Copy to library: If you’re importing media from a different disk or volume, or if you want to keep a copy of all the media files that have been imported into KeyFlow Pro in the same location (in the KeyFlow Pro library), select this option. (by default)
    - Leave files in place: You can select this option to link to the files in their current location rather than copy them into the KeyFlow Pro library. In that case, KeyFlow Pro creates reference files (file aliases) that simply point to the source media files without copying them. There are advantages that enable to use the existing devices as it is.
    - Store To: In KeyFlow Pro 1.1.5 or later, you can set source media location for reference files. This option is a part of referenced (Leave files in place) import, so media can be imported (or copied and then indexed) to any location on a connected volume as external media.
  • Q

    When I select ‘Leave files in place’ option, a volume selection window pops up. I selected the storage volume containing files being imported, but ‘Allow’ button is disabled. What should I do?

    A
    You must select a root volume (e.g. Macintosh HD), not the specific storage volume on which the importing files are located. It’s for your convenience. You may have another external hard drives to import files with ‘Leave file in place’ option. Once you allow to access root volume, you can import files with ‘Leave file in place’ for any drives without being prompted again.
  • Q

    What is the difference between existing Projects and new Live Folders?

    A
    The existing Projects are used by importing media manually into library for reuse of media from previous projects that are being archived. In this case, you can filter the media and import it into the library selectively as well as apply the workflow automatically to the project during import. Before importing, you can choose between “Copy to library” or “Leave files in place (or Store-to)”. You can batch relink the media to changed location path when the files are moved to the different volume or folder. (for reference media only.) ** Note: Once the imported files cannot detect the changes of the original file, so you have to import it again If the linked original file has changed. The new Live Folders are used by adding current working folders that are updated frequently as Live Folder. All the media in Live Folders are imported immediately, and the changes in the Finder level are updated automatically. For example, when you rename a sub-folder or add(or delete) a file, the changes are automatically updated in the Live Folder. Your current folder structure remains unchanged, so you can manage all of your media files in Live Folder at the Finder level. You can apply workflow to the selected assets in the Live Folder manually. The media assets in Live Folders can be dragged-and-dropped into the Project (or Group) above. Then, it will exist in both the Project (or Group) and the Live Folder, even if the Live Folder is deleted from the list, it remains in the Project as a reference type. ** Note: Except for images, once generated preview files and thumbnails will not be regenerated(updated) automatically if the original file has changed. And the Batch Relink feature cannot be applied to the Live Folders.
  • Q

    What should I attention when I use Live Folders feature?

    A
    - Please note that Scan Performance of the Live Folders is affected by the network(infrastructure) environment. So, the KeyFlow Pro library should be stored into the local hard disk (of the server) for the best scan performance of the Live Folders. - Renaming or moving folder affects many sub-files, so it is recommended that you avoid excessive changes in Live Folder as much as possible. - The Live Folder will appear offline if you rename a top-folder or if the location of the Live Folder has changed. - Please be careful that if you delete a Live Folder from the list and add it again, the metadata you entered will be lost. - When the Live folder is already being scanned, Auto Scan is in the standby status. After all the Live Folders have been scanned, the Auto Scan is automatically performed for all the Live Folders after the Interval time (set in the Preferences) has elapsed. If the manual scan is performed frequently, the Auto Scan is performed after all the manual scans have been completed. Therefore, if the interval is long and the manual scan is frequently performed, the Auto Scan may still be in the standby status. (Interval counts time after all scans are completed, so time will be pushed back.)
  • Q

    After the library moved to other location, I cannot re-import the library. What’s going on?

    A
    Be sure to quit KeyFlow Pro before moving a library. After moving the library, you have to delete the existing library first from the Library List (View > Show Library List) before you re-import the library. Don’t worry, the actual library will not be deleted although deleted from the Library List.
  • Q

    Suddenly I can’t see the location information in the Map view mode. What happened?

    A
    Make sure that your Mac is connected to the internet.
  • Q

    When I import video, a low-res file for preview was not created. Why?

    A
    Maybe you didn’t check the preview option in Preferences. Go to the Preferences, click Encoder pane, then check "Create Preview File during Import" option Before you import. In KeyFlow Pro 1.5 or later, even if you didn’t check the preview option before you import, you can create a preview file manually using “Create Preview File” option in the context menu.
  • Q

    What is the resolution of the Low-Res video for preview?

    A
    In KeyFlow Pro 1.5.2 or later, 960x540 is the default resolution. You can choose the resolution for preview in the Encoder pane of the Preferences before you import.
  • Q

    How does the workflow assigned to the project work?

    A
    The workflow will be performed automatically when importing the media files if workflow operating conditions are set. You can assign workflows to specific project, or apply a workflow to the selected media assets anytime.
  • Q

    Can I monitor the workflow status?

    A
    Yes. You can real-time monitor the workflow status in the workflows on the bottom of Inspector. Also you can monitor the background jobs status in the pop-up window by clicking the background jobs icon on the bottom left of inspector. (View > Show Background Jobs)
  • Q

    Can I apply a workflow to watch folder?

    A
    Yes. This feature is supported in KeyFlow Pro 1.1 or later.
  • Q

    Does Watch Folder continuously rescan the folders for any changes or additional files?

    A
    No. It does not currently do so. It is only Move media files automatically into the specific project of your library. We’ll consider it later.
  • Q

    Is it possible to add the custom metadata fields into the search conditions?

    A
    Yes. You can set in the Search tab of Preferences.
  • Q

    How can I connect to shared library?

    A
    KeyFlow Pro has great flexibility in any network connections. You can easily connect to shared library via Bonjour, LAN, VPN and Wi-Fi connection. In order to connect to the shared library, choose File > Connect to shared library(or press Command-K), then enter the server informations and click Connect button. Once the libraries are connected to your KeyFlow Pro, you can freely switch between shared libraries in the Library List.
  • Q

    Do client users need to purchase the app individually for each Mac when they connect to the shared library(server)?

    A
    In a workgroup, they don’t need to purchase the app individually for each Mac they want to use it on. For example, if they can share an Apple ID(e.g. Company’s Apple ID), they can install KeyFlow Pro on their Mac. Then, 5 client users can connect to the shared library(server) simultaneously. If they need more than 5 users, please purchase the additional items via In-App Purchase.
  • Q

    Can I connect to the server from another device with the same user ID?

    A
    Not at the same time. When logging in from a second device, you can choose which connection to keep active.
  • Q

    Can I modify the metadata of media asset in the shared library?

    A
    Yes. This feature is supported in KeyFlow Pro 1.5 or later. Creatable and Editable permission are added for the shared library (selectable). Creatable enables upload and duplicate media remotely. (Creatable includes Editable permission.) Editable enables edit Tags, Metadata, Annotation, etc. remotely.
  • Q

    Why are some of contextual menu items disabled in the shared library?

    A
    You need to mount the network volume where the shared library is located first in the Finder. After the network volume has been successfully mounted, then when you click the Auto Search button in the Library Information (View > Show Library Information), all of context menu items will be activated, and media offline items are changed to media online. If you cannot mount the network volume, you can use the media assets by download.
  • Q

    When sharing KeyFlow Pro libraries over the network, is it possible to keep the footage on a shared storage such as SAN, NAS, then use these clips without downloading them?

    A
    Yes. If the footages on a shared storage have been imported into a KeyFlow Pro library with “Leave files in place” option, client users can browse the footages and drag and drop it from KeyFlow Pro to Final Cut Pro X automatically links to the original footages on the shared storage. The point is that the path to the shared storage should be same on all machines.
  • Q

    When I connect to shared library, the volume path was same and correct volume mounted but the media files are still offline. Why is this?

    A
    You must click the Auto Search button in the Library Information. (View > Show Library Information)
  • Q

    Does KeyFlow Pro support image sequences file?

    A
    Currently each image file is handled as a single asset. But we know that users may need to handle image sequences smarter in our software such as Motion does. We are trying to find out the best way to support this feature.
  • Q

    How do I use boolean operators?

    A
    KeyFlow Pro supports AND and OR boolean operators and phrase searching using the "quote marks”. Title, Tags and File Extension are default search field. You can add more metadata fields to search in Preferences. Here are some examples. 1. Using AND The following search results in the files that have both A and B. A B A and B A AND B 2. Using OR The following search results in the files that have either A or B. A | B A or B A OR B 3. Using “quote marks” The phrase embraced by “quote marks” is handled as a single search string. The following search results in the files that have the phrase of “A is B”. “A is B” 4. You can not use AND and OR operators at the same time. For example, the following search are not supported. A | B C A and B or C Note. The NOT boolean operator is not supported. An error occurs if the pair of quote marks does not match.
  • Q

    How do I backup the library of the KeyFlow Pro?

    A
    KeyFlow Pro collects all files as managed media assets inside the library package for easy to share, move, and backup. When you create a new library, it’s automatically included in the active library. The library contains original media files, associated database, metadata, low-res video for preview and thumbnail images in one location you selected. If you want to back up the KeyFlow Pro library, you can easily copy the library package, that’s all. In KeyFlow Pro 1.6 or later, KeyFlow Pro supports automatic database backup (6-hour intervals) and migration from inside library to local storage.
  • Q

    How do I completely uninstall the KeyFlow Pro?

    A
    To uninstall the KeyFlow Pro on a Mac, follow the steps below. 1) Quit KeyFlow Pro (Quit FCPX Agent for KeyFlow Pro if needed) 2) Delete the directory below. /Applications/KeyFlow Pro ~/Library/Group Containers/2DNBVEVS78.com.malgn.KeyFlow-Pro/

FCPX Agent

  • Q

    What versions of Final Cut Pro X work with FCPX Agent?

    A
    FCPX Agent requires Final Cut Pro X 10.1 or later.
  • Q

    Can I export to shared library directly using FCPX Agent?

    A
    Yes. But you need to mount the network volume where the shared library is located first in the Finder.
  • Q

    When I export using FCPX Agent, I cannot select the project(group), since the library appears offline. What do I do?

    A
    First of all, be sure to check the KeyFlow Pro is running. After launching the KeyFlow Pro, you can connect and select the project(group) of library.
  • Q

    Can I upload the tags I entered when exporting media file using FCPX Agent to the KeyFlow Pro?

    A
    Yes. The tags are automatically uploaded to the KeyFlow Pro and you will be able to see the same tags of the media file in the Finder. Also you can see the metadata you entered in Final Cut Pro X on the Final Cut Pro X metadata group of KeyFlow Pro.
  • Q

    Can I export the QuickTime Movie file only (except FCPXML file) using FCPX Agent?

    A
    No. You can export either ‘QuickTime Movie & FCPXML’ or ‘FCPXML only’.
  • Q

    How do I completely uninstall the FCPX Agent for KeyFlow Pro?

    A
    To uninstall the FCPX Agent on a Mac, follow the steps below.
    1) Quit KeyFlow Pro and FCPX Agent for KeyFlow Pro
    2) Delete the directory below.
       /Applications/FCPX Agent for KeyFlow Pro
       ~/Library/Group Containers/2DNBVEVS78.com.malgn.KeyFlow-Pro/FCPXAgent